[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[aspell-devel] address@hidden: Bug#307611: aspell-bin: Soundslike is not

From: Brian Nelson
Subject: [aspell-devel] address@hidden: Bug#307611: aspell-bin: Soundslike is not used when looking up corrections]
Date: Wed, 4 May 2005 10:01:27 -0700
User-agent: Mutt/1.5.9i

Hmm, is soundslike really broken in 0.60.3-20050121?

Society is never going to make any progress until we all learn to
pretend to like each other.
--- Begin Message --- Subject: Bug#307611: aspell-bin: Soundslike is not used when looking up corrections Date: Wed, 04 May 2005 09:23:32 +0200
Package: aspell-bin
Version: 0.60.2+20050121-2
Severity: important

Even for dictionaries with "soundslike" activated, Aspell does not use
soundslike when looking up corrections.  A demonstration:

First the preparations:

% sudo apt-get install aspell-fr
% echo $'bordeaux\nbordo' > test_soundslike

Exactly the same problem also exists in Danish, but here we use the
French dictionary, since there are reported other bugs against

Now we check the "soundslike" of the two words:

% LANG=fr_FR aspell soundslike < test_soundslike
bordeaux        PORTO
bordo   PORTO

As you can see, Aspell knows that these two strings would be
pronounced roughly the same.

Then ask Aspell to check the file for misspellings:

% LANG=fr_FR aspell check test_soundslike

Aspell (correctly) accepts "bordeaux".

Then it (also correctly) complains about "bordo".  But the suggestions
for correcting the error are:

1) bord                                 6) borde
2) ordo                                 7) bord
3) bords                                8) porto
4) boldo                                9) bordai
5) borda                                0) bordons

Of which only "porto" has the same soundslike as "bordeaux" and

This error basically means that the Aspell version in Debian is no
better than Ispell, while it is wasting more disk space and doesn't
have to code-maturity which Ispell has.

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: powerpc (ppc)
Kernel: Linux 2.6.8-powerpc
Locale: LANG=fo_FO.ISO8859-1, LC_CTYPE=fo_FO.ISO8859-1 (charmap=ISO-8859-1)

Versions of packages aspell-bin depends on:
ii  libaspell15            0.60.2+20050121-2 The GNU Aspell spell-checker runti
ii  libc6                  2.3.2.ds1-21      GNU C Library: Shared libraries an
ii  libgcc1                1:3.4.3-12        GCC support library
ii  libncursesw5           5.4-4             Shared libraries for terminal hand
ii  libstdc++5             1:3.3.5-12        The GNU Standard C++ Library v3

-- no debconf information

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]