[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [aspell-devel] patch to fix for g++ -O3

From: David Fang
Subject: Re: [aspell-devel] patch to fix for g++ -O3
Date: Fri, 5 Jan 2007 20:15:53 -0500 (EST)

> I applied the fixes to a fresh copy of 0.60.5 then tried:
> tar -xzf ../aspell-0.60.5.tar.gz
> md z
> cd z
> ../aspell-0.60.5/configure -srcdir=../aspell-0.60.5/
> ./make
> <snip>
> cd gen; perl
> /usr/local /usr/local/lib/aspell-0.60 /usr/local/lib/aspell-0.60 
>  /usr/local/etc
> >  dirs.h
> Can't open perl script "": No such file or directory
> make[1]: *** [gen/dirs.h] Error 2
> make[1]: Leaving directory `/home/digital/temp/z'
> make: *** [all-recursive] Error 1

        After applying the patch, did you run 'autoreconf' to regenerate  I've been testing on Mac OS X 10.4.8.  Also, when I
configure'd, I didn't have to pass the -srcdir argument, but that should
make no difference (configure figures it out).

my commands:
tar xzvf aspell-0.60.5.tar.gz
cd aspell-0.60-5
patch -p1 < ../aspell-0.60.5.patch
mkdir build
cd build
../configure CFLAGS="-g -O3" CXXFLAGS="-g -O3" -C
make check

> This was tried with Mandriva 2007 and it appears to have problems with the
> dots where instead of -0.60.5 it sees 0.60 (see mk-dirs line above).
> I'm sure you're on the right path towards fixing the srcdir != builddir

Does it still fail for you?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]