[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Aspell-user] replacement list not working

From: Nikolai Buer
Subject: Re: [Aspell-user] replacement list not working
Date: Sat, 20 Sep 2003 18:03:22 +0200
User-agent: Mutt/1.5.4i

Actually, it turns out that the list works, only not for the "aa å"
replacement. I'm still trying to find out for which combinations it

For example, the replacement "aab å" works (if I type it aab, it will
suggest å) but not for aaa or aaaa, but it works for bb.

I don't know why it behaves in this way, it seems to work for any
combination, only not for a's. In Norwegian this is a replacement that
is needed because aa really is a substitute for å (it sounds like it,
and is used by people writing in Norwegian using an english keyboard).

There is still no soundslike pattern written for the norwegian
dictionary, but is there a way of including this replacement "aa å" now
that this doesn't work thruogh the replacement wordlist?


On Mon, Sep 15, 2003 at 09:57:40AM +0200, Nikolai Buer wrote:
> Hi.
> I can't get the replacement list to work properly with aspell. The
> english one works fine, but the norwegian one seems to ignore the
> replacement list.
> Here's my replacement list in my home dir ~/
> personal_repl-1.1 no 0
> aa å
> The thing is that I want it to suggest å as a replacement for aa. If I
> add the "aa å" replacement in the english dictionary it works fine, but
> it is in the norwegian one I need it. I've also tried specifying on the
> command line which replacement list to use, like this.
> $ aspell --lang=no -a
> @(#) International Ispell Version 3.1.20 (but really Aspell 0.50.3)
> aa
> # aa 0
> No errors, it just ignores it.
> I use Debian (sid) and I've tried both the packages and building my own
> with the tar balls, but it still doesn't work. There seems to be a
> problem because norwegian uses two dictionaries, bokmål and nynorsk, and
> I had symlink bokmål.dat to no.dat in /usr/share/aspell.
> Here are some config dumps.
> $ aspell config repl
> .aspell.en.prepl
> $ aspell --lang=no config repl
> $ aspell -d norsk config repl
> .aspell.<unknown>.prepl
> For some reason "aspell -d norsk" and "aspell --lang=no" returns
> different dumps, I'm sure there is a trivial answer to this, but I have
> been unable to find out why.
> I also put "lang no_NO" in ~/.aspell.conf, but it didn't make any
> difference.
> Any ideas would be appreciated.
> nikolai.
> _______________________________________________
> Aspell-user mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]