[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Aspell-user] aspell-<LANG>: Invalid UTF-8 sequence at position...

From: Martin Swift
Subject: Re: [Aspell-user] aspell-<LANG>: Invalid UTF-8 sequence at position...
Date: Wed, 7 Mar 2007 22:48:34 +0900
User-agent: Mutt/1.5.13 (2006-08-11)

On Tue, Mar 06, 2007 at 11:00:35PM -0700, Kevin Atkinson wrote:
> [Putting address@hidden back on the list]
> On Wed, 7 Mar 2007, Martin Swift wrote:
> >On Tue, Mar 06, 2007 at 08:37:24PM -0700, Kevin Atkinson wrote:
> >>>Just in case it helps, /etc/aspell/aspell.conf has only a single line:
> >>>
> >>>encoding utf-8
> >>
> >>That did it.  Aspell ignores the locale settings when creating word lists
> >>but it doesn't ignore the config files.  I need to fix this some how.  But
> >>I don't know how best to do it.   For now try setting this in your
> >>environment before compiling the word lists
> >>
> >>  ASPELL_CONF="conf /dev/null"
> >
> >That environment variable didn't help, but temporarily moving the
> >config file to a different name, did.
> It should have.  I just tested it and it worked for me.

Well, I tried again:

  # export ASPELL_CONF="conf /dev/null"
  # echo $ASPELL_CONF 
  conf /dev/null
  # sudo emerge -av aspell-is

... and no dice. The command

  /usr/bin/word-list-compress d < is.cwl | /usr/bin/aspell  --lang=is create 
master ./is.rws

just spits out the same old error message. Could you otherwise
reproduce my problem exactly?

> >As for fixing the problem; is there a reason why you can't just read
> >the the *.dat file last and overwrite the previous settings?
> It's probably not that simple.  I will need to study the problem more 
> before I can answer that question.  I suggest you file a bug report.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]