[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] Hint, hint...

From: David Kastrup
Subject: Re: [AUCTeX-devel] Hint, hint...
Date: Mon, 27 Jun 2005 18:19:18 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

Jan-Ake Larsson <address@hidden> writes:

> David Kastrup wrote:
>>>I have finally a few minutes off and can do the tightpage special
>>>for some testing. But I don't know how to get the version number, so
>>>I cannot insert that. Sorry.
>> \fileversion should do the trick, at least in the last version I
>> checked in.  Basically, something like
>> \AtBeginDvi{\special{ps::(preview-latex \fileversion}%
>>   \special{ps::magic_cookie_for_older_dvipng_versions}%
>>   \special{ps::)pop}
>> should work for now.
> I've checked in something that will make both dvipng <=1.5 happy
> and >= 1.6, and comments to make it evident what is needed when
> this compatibility code is to be removed.
> It seems that \fileversion does not work in preview.sty, I haven't
> got time to check why.

Most probably because I am an idiot.  It would work while typesetting
preview.drv, but that's not really useful.

You'd probably need to do \GetFileInfo{preview.sty}, but I don't know
whether this is workable in preview.sty itself, and I don't know
whether this might not have side effects on other packages using

Ok, so I changed something.  Use address@hidden for getting the version:
this should work unless I did something terribly wrong.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]