[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] Fold citep

From: Ralf Angeli
Subject: Re: [AUCTeX] Fold citep
Date: Fri, 30 May 2008 22:35:06 +0200

* Joost Kremers (2008-05-18) writes:

> i'm sure it's possible, but it might not be so easy to implement. you'd
> want a user to be able to specify something like "(#1)", in which #1 is
> going to be replaced with the first argument. this needs to be converted in
> the proper format string + argument to feed to FORMAT. i don't immediately
> see an easy way to do that...

I've now checked in the possibility to specify macro arguments to be
used as a replacement in the display string with a "{<num>}" syntax.
This works only for mandatory arguments.  I've started to implement the
same for optional arguments with "[<num>]" but this would probably
require the possibility to supply an alternative string if the optional
argument is not found.  I'm not sure yet how to do that, perhaps with
something like "[<num>:<alt_string>]", if it is really necessary.

>> By the way, do you have copyright assignment papers for AUCTeX on file?
> no, i don't. but you're happy to use those few lines of code i wrote in any
> way you see fit. ;-)

The amount of original lines in the patch borders at the limit for
requiring a copyright assignment.  I've checked it in as a tiny change,
but should you provide another patch we'd require the assignment.

> i applied the patch to tex-fold.el from 11.85, which went fine. folding a
> region works as intended, but i'm having a problem with TeX-fold-buffer.
> the problem appear to be in the call to jit-lock-fontify-now.
> it seems that on my emacs, the combination of jit-lock-fontify-now and
> auctex is problematic. when opening a latex file, the file seems to be
> fontified properly, but the *Messages* buffer does show errors:
> Error during redisplay: (void-function nil) [4 times]

Does this happen all the time or only in special files?  In case of the
latter you might want to provide a sample file for reproducing the
problem.  Before that you should check if a special setting is required
by trying to reproduce the problem in an Emacs session without your
personal settings, e.g. by starting Emacs like this:
emacs -Q -l auctex


reply via email to

[Prev in Thread] Current Thread [Next in Thread]