[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] /bin/sh: latex: command not found (but it works in the terminal

From: Al Erickson
Subject: [AUCTeX] /bin/sh: latex: command not found (but it works in the terminal version)
Date: Fri, 29 May 2009 12:45:31 -0700

I installed auctex and preview. I open a .tex file with emacs (GNU Emacs and get the right menus that tell me it installed auctex and preview. This is on Mac OS 10.5, I use TeXLive 2008 which is installed at /usr/local/texlive/2008/ and latex's "/bin" folder is aliased from /usr/texbin/ (I think it is a pretty standard install). LaTeX (C-c C-c) works normally in terminal emacs but not in the graphical version. Instead I get the error message:

Running `LaTeX' on `ksegs' with ``latex -interaction=nonstopmode "\input" ksegs.tex''
/bin/sh: latex: command not found

LaTeX exited abnormally with code 127 at Fri May 29 01:21:15

The problem was previously addressed at where the original poster says he found the problem is known to be intermittent (I asked him about it and he didn't have anything further on the topic). I didn't find any other evidence of that though...

for what it's worth, /usr/texbin is in the sh terminal path.
sh-3.2$ echo $PATH
/sw/bin:/sw/sbin:/usr/games:/Library/Frameworks/Python.framework/ Versions/Current/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/ texbin:/usr/X11/bin:/usr/texbin:/usr/local/bin:/usr/X11R6/bin

Thanks for your help. If it's a bug, let me know and I'll try to report it. I hope Mail doesn't turn out to be HTML mail. Lastly, please consider that I tend to stumble my way through Unix and have never used a mailing list. Clear advice and instruction is appreciated.

Alejandro Erickson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]