[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] font-latex-user-keyword-classes doesn't work

From: Ralf Angeli
Subject: Re: [AUCTeX] font-latex-user-keyword-classes doesn't work
Date: Sun, 11 Apr 2010 16:34:00 +0200

* micheal S. (2010-04-08) writes:

> On Thu, Apr 8, 2010 at 5:54 PM, Ralf Angeli <address@hidden> wrote:
>> * micheal S. (2010-04-07) writes:
>>> I would like to have syntax highlighting for user defined LaTeX commands.
>>> The auctex manual says, this could be done by setting the variable
>>> font-latex-user-keyword-classes.
>>> I've tried it (via M-x customize-variable), but unfortunately there
>>> was no effect.
>> Did you restart Emacs after that?
> Yes I did. Restarting emacs didn't help.

Okay.  I checked your customization and saw that you did not provide any
keywords to be matched.  You only gave the name of the class.  So in
theory it should work once you add the keywords.  However, I found a bug
in the code dealing with face properties for LaTeX commands without
arguments, which prevents them from being fontified.  This is fixed in
CVS now.

If you really want to highlight a command without arguments, like \foo,
(in contrast to one with arguments, like \bar{baz}), then you can
specify an existing face instead of setting face properties in the
customization interface.  In your setting you already use the name of
such a face but as the name of a font family which will not work.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]