[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] have AUCTeX insert the encoding as local variable specifica

From: jfbu
Subject: Re: [AUCTeX] have AUCTeX insert the encoding as local variable specification
Date: Sat, 29 Nov 2014 12:12:57 +0100

29 nov. 2014 at 09:45, David Kastrup wrote :

>> Makes me think that there could be a one-time-only
>> parsing of the .emacs and customization files when
>> a new Emacs major release is first executed by the
>> user, so as to signal possible mis-configuration.
> customize-changed-options is an interactive autoloaded Lisp function
> in `cus-edit.el'.
> It is bound to <menu-bar> <options> <customize>
> <customize-changed-options>.
> (customize-changed-options &optional SINCE-VERSION)
> Customize all settings whose meanings have changed in Emacs itself.
> This includes new user options and faces, and new customization
> groups, as well as older options and faces whose meanings or
> default values have changed since the previous major Emacs
> release.
> With argument SINCE-VERSION (a string), customize all settings
> that were added or redefined since that version.

Thanks for the tip, 

M-x customize-changed-options 
creates a giant customization buffer, I am not sure
what I am supposed to do with it. It just makes me realize 
I know close to nothing to all modes provided with Emacs.

I guess people updating very regularly their Emacs and
doing M-x customize-changed-options systematically on each
minor version increment find  usefulness in this big customization 

But I am interested in a function which would look only at what is actually 
customized in my customization file; the only things I am interested to review
are the things that I customized myself years ago, it is only those things
which I need to compare to the current default values. 

(by the way I observed that also my auto-coding-alist was quite obsoleted, 
I don't even recall why I had it in my custom file to start with)

a note in passing: I got
    dbus-call-method: peculiar error: "Emacs not compiled with dbus support"
after giving 23.1 (or anything earlier I tried) as SINCE-VERSION argument. 

No problem with 23.2 though.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]