[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
31 Oct 2000 11:34:07 +0100
Gnus/5.0807 (Gnus v5.8.7) XEmacs/21.1 (Channel Islands)
| | On Oct 27, 2000, Akim Demaille <address@hidden> wrote:
| | > (_AC_DIAGNOSE, AC_DIAGNOSE): Rename as...
| | > * m4sugar.m4 (m4_warning_ifelse, _m4_warning_ifelse)
| | Under the same reasoning, I think we should keep AC_DIAGNOSE as an
| | alias to its m4sugar implementation, and use AC_DIAGNOSE in autoconf
| | code, so that, if we ever decide to make some change in the diagnostic
| | output that is specific to autoconf, we can do it by replacing the
| | alias with a macro, instead of having to modify m4sugar because of
| | some autoconf's need.
| I understand your concern, but I confess I am more attached to keeping
| each stuff in its own name space.
| In the precise case of m4_warn vs AC_DIAGNOSE, since we are talking
| only about M4 itself, I can't see how we could want to depend upon
| something proper to Autoconf. If we were to change something, then
| chances are high that we'd want to change m4_warn too. If we need to
| introduce something really new and for Autoconf only, then we can
| introduce a new macro to this end, which will, btw, release us from
| the problems of compatibility (while we would have met some had we
| kept AC_DIAGNOSE).
| So I don't really know. I'm really attached to spreading the use of
| pure M4sugar in Autoconf, but I'm receptive to your argument.
So what do we do? Shall I leave AC_DIAGNOSE in Autoconf?
Honestly, if Autoconf were to be developed today, I'd get rid of
AC_WARN and AC_DIAGNOSE in favor of m4_warn, and replace AC_MSG_WARN
with AS_WARN. My whole point is precisely to keep the prefix
But I understand your preoccupation for de-correlating the layers :(
Hm. After having talked with myself for a while, I think I'm more
attached to keeping things in its own layer...
Your call Alexandre. I'd like to hear from you too Pavel.