[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: building with older Automake

From: Ralf Wildenhues
Subject: Re: building with older Automake
Date: Tue, 4 Dec 2007 21:49:03 +0100
User-agent: Mutt/1.5.13 (2006-08-11)

Hi Eric,

* Eric Blake wrote on Tue, Dec 04, 2007 at 06:36:44PM CET:
> I was annoyed that a with fresh git checkout, 'autoreconf -fi' downgraded 
> texinfo.tex;

So don't use --force.

> I traced it to the fact that I was not using bleeding-edge 
> automake.  This fixes it, so I'm committing.

Well, the "fix" would be to release Automake 1.10.1.  This is just an
ugly workaround around the licensing holdup.  Please let's not go this
way even further.

Let's write to Brett again, this situation of waiting more than half a
year is utmost ridiculous.  We should at least be given the chance to
release either in the state licenses are done now, or with GPL2 (given
consent of recent contributors).

> But it does raise the question - does autoconf's really
> work with automake as old as 1.7.9,

Yes, last I tested it was a month ago or so.

> or should we up our minimum requirement to 1.9.6 or 1.10?

Of course that can still be done.

> It also raises a documentation bug against Automake - the manual
> mentions no-texinfo.tex, but neither the manual nor NEWS mention when
> it was added.

Please submit a patch, thanks.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]