[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Autoupdate doesn't like AC_LINK_FILES

From: Akim Demaille
Subject: Re: Autoupdate doesn't like AC_LINK_FILES
Date: 25 Sep 2000 10:40:35 +0200
User-agent: Gnus/5.0807 (Gnus v5.8.7) XEmacs/21.1 (Channel Islands)

| Hello!
| I tried to run autoupdate on the following

Thanks Pavel, I'll try that.

| and it printed:
| /tmp/au9096/input.m4:45: /usr/bin/m4: Non-numeric argument to built-in 
| /tmp/au9096/input.m4:45: /usr/bin/m4: Cannot open [/tmp/au9096/disable.m4]: 
No such file or directory
| /tmp/au9096/input.m4:45: /usr/bin/m4: Cannot open [/tmp/au9096/unm4.m4]: No 
such file or directory
| Does it work for anybody? The first message appears to be a bug in m4
| (version 1.4).

Yep, I ran in it several times.  There are also very funny things
happening when you use no quotes:

~/src/ace % m4 -daeqc -t undefine -t define                      nostromo 10:37
m4trace: -1- undefine ...
m4trace: -1- undefine(`undefine') -> ???
m4trace: -1- @@8(...)

define(foo, bar)
m4trace: -1- define ...
m4trace: -1- define(foo', bar') -> ???
m4trace: -1- define(...)

| Maybe we need tests for all obsolete macros that they can be updated?

Overkill IMHO, but it's a good idea to write on for this one which has
been broken several times.

OTOH, maybe we can have an automatic test suite for these, just like
macros.m4.  It would use a macro which 1. creates the
with an obsolete macro, 2. autoupdate it, 3. autoconf & autoheader it,
and 4. run the configure.  Sounds good.  Doesn't it?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]