[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Success (mostly) with the testsuite

From: David Morgan
Subject: Re: Success (mostly) with the testsuite
Date: Fri, 13 Oct 2000 09:16:53 -0700

Hi Pavel,

Initial testing is NOT going well.

On the Solaris 8 box that I am testing on the make check failed with a missing
automake and a missing makeinfo.  I installed automake 1.4 and a dummy makeinfo.

I have a:

tools.m4:164 ignored near `tools.m4:183'

I'm not sure what to do with the ignored as I got some on my Linux box as well.

I also tried on a QNX box (our torture test box for building our products)

The configure script bombs out while creating config.status with a message
 sed: 2:
         /^X\(.*^/\)\/\/*^ ...": RE error: parentheses not balanced

So it looks like we need some work on the RE's for a bad sed :(

What else would you like to know - we don't have the native cc in house
just the brain dead /usr/ucb one.

I also have other boxes if need be.


Pavel Roskin wrote:
> Hello, David!
> > What would you like done on what version of Autoconf and what version of 
> > Solaris
> > and do you want the native compiler tested or will GCC be ok?
> >
> > Let me know and I'll see what can be done.
> Well, I just realized that even
> make SHELL=/bin/ksh CONFIG_SHELL=/bin/ksh check
> won't prevent "configure" from being run by /bin/sh. Only config.status
> would be run by /bin/ksh. Time to retest everything :-(
> So, for now please run the following:
> make check
> CC=cc make check
> Ignore 4 errors in update.m4
> I'm sure that the testsuite will be in a better shape very soon, but it's
> very important to catch real errors on really used systems (i.e. with your
> shell and your compiler) as soon as possible.
> Regards,
> Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]