[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf complains wrongly about version of m4

From: Bob Proulx
Subject: Re: autoconf complains wrongly about version of m4
Date: Sun, 20 May 2001 03:09:24 -0600

> However, I'm now trying to use autoconf 2.13 at work on an HP-UX system,
> with little success. Sorry I can't reproduce the exact error message

I have built autoconf/automake both on HP-UX 10.20 and HP-UX 11.0 with
no real trouble.  But autoconf-2.13 does not work very well on HP-UX.
Note that you really want at least test beta autoconf-2.49c or later
to get most HP-UX support right and probably will want the very latest
versions to get everything right.  As soon as the eminent release of
2.50 happens be sure get it for full HP-UX functionality.

> (I'm not on the machine), but autoconf complains that it needs gnu m4,
> version 1.1 or greater. However, I've installed m4, version 1.4. typing
> m4 --version correctly identifies itself as version 1.4. To my knowledge
> there are no older versions of m4 around, but in any case, the version I
> want to use (1.4) is in the path, and 'which m4' indicates that the one
> I want is being picked up. 

Works fine for me.

checking for m4... /usr/local/bin/m4

And from there everything is normal.  My path is set:
PATH=/usr/local/bin:/usr/bin:/usr/ccs/bin such that GNU m4 is found in
path before the system /usr/bin/m4 version.

If you get into a real bind I can make a built tarball or rpm package
of my hpux files available to you.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]