[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AC quoting rules

From: Paul Eggert
Subject: Re: AC quoting rules
Date: Thu, 7 Feb 2002 16:06:30 -0800 (PST)

> From: Akim Demaille <address@hidden>
> Date: 07 Feb 2002 11:30:33 +0100
> Err, first of all, if you are talking about novices, strip the cache
> part, and go down to

But we shouldn't strip the cache part.  Caching should be the normal
case.  It should be easy to do, not hard.

> [Simplification] has to been done calmly, with a whole
> period of development dedicated to itself alone.

I quite agree.  We both need more free time.  :-)

> As far as AC_TRY_LINK goes, I'm really against it: it is the very
> Cartesian product I'm referring to.

Sorry, I don't quite understand your point about the Cartesian
product.  I agree that AC_TRY_LINK should be simplified, but I'm not
sure where you're headed.

To be honest, I'd rather have something like this:

    [AC_LIBSOURCES([error.c, error.h])
     AC_TRY_LINK(, [error_at_line (0, 0, "", 0, "");]) || AC_LIBOBJ(error)])

The idea is to use shell syntax rather than IFELSE when programming
something that is executed at runtime by 'configure'.  This is partly
because the shell syntax is more readable than IFELSE, and partly
because using a different syntax makes it easier for readers to
distinguish autoconf-time actions from configure-time actions.

(I realize that I am handwaving here, and that the discussion has
veered back to controversial syntactic issues.  :-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]