[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Paul Eggert
Subject: Re: LIBOBJS and ANSI2KNR fix?
Date: Sun, 24 Mar 2002 21:52:57 -0800 (PST)

> Date: Mon, 25 Mar 2002 00:17:45 -0500
> From: Harlan Stenn <address@hidden>
> The NTP software currently requires 2.49,

That's too bad.  2.49 was never an official release.

> and I heard an unconfirmed rumor that 2.50 no longer works to
> autoconfig NTP.  People get Upset with me every time I bump the
> version of autoconf that is required to build NTP, and given that
> the LIBOBJ cannot be used with 2.53 and isn't needed with 2.52, I
> would like to know what version of autoconf I need to require.
> I hope I'm making sense...

I suppose you can use AC_LIBOBJ if it's defined, and if not, you can
assign to LIBOBJ indirectly, in a way that Autoconf can't tell about.
E.g. "eval 'LIB''OBJ'='value'".  It'd be ugly, but it'd work, I think.
But you're on your own if you play tricks like that....

Personally, I would just bump the version of Autoconf to 2.53.  If you
want to develop software, you gotta keep your tools sharp.  It's
unwise for NTP to require developers to use an unreleased, unsupported
version of Autoconf.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]