[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: different gccs

From: Ralf Corsepius
Subject: Re: different gccs
Date: 14 Jul 2003 14:12:33 +0200

On Mon, 2003-07-14 at 01:35, Bob Lockie wrote:
> This is based on behavoir/assumptions.
> I think libsupc++ is included in gcc-2x but not in gcc-3x.


> I need libstdc++ in gcc-2x but I need both libstdc++ and libsupc++ in 
> gcc-3x but libsupc++ does not exist in gcc-2x.
OK, here you say it. libsupc++ is shipped with gcc-3.x

> AC_CHECK_LIB( stdc++, main, , AC_MSG_ERROR( [*** stdc++ library is 
> required ***] ), )
> AC_CHECK_LIB( supc++, main, , AC_MSG_ERROR( [*** supc++ library is 
> required ***] ), )
> Are my assumptions correct and how can I write a that works 
> regardless off gcc version?
You don't have to check for libsupc++. libsupc++ is an internal
implementation detail of gcc-3.x you should not have to care about nor
to check for. "g++" will automatically link against it.

However, I guess the origin of your problem is using "gcc" to compile
and link C++-application. This previously had worked with gcc < 3.0 on
some platforms, but with gcc >= 3.0 using "g++" to compile/link
C++-applications is mandatory and probably will fix your problems.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]