[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

question about configuring autotools

From: Graham Mark
Subject: question about configuring autotools
Date: Sun, 9 Oct 2005 13:27:16 -0600

I'm having trouble configuring the autotools. To explain my trouble I need to explain what I'm doing.

I help to support a bunch of software that uses 10-15 third-party packages, including autotools. I'm trying to set up a directory structure that will make it reasonably easy to replace an outdated release of any one of these packages with its current release. "Easy" would mean that users of these packages would not have to change paths in makefiles or scripts, and that performing the replacement would not be unduly burdensome. For various reasons I have to do this outside of the usual system directories.

My idea is to have a structure like this:


The subdirectories under 'current' would hold pointers to appropriate elements in autoconf-M.N, automake-X.Y, and so on. When a new version of autoconf, say, is released, it would be installed in 'third-party' and the current pointers would be reset to point in there.

I have installed autoconf-2.59, automake-1.9.6, gcc-3.4.4 (holding off gcc-4 for now), libtool-1.5.18, and m4-1.4.3, among others. These were all configured with the appropriate '--prefix' flag. 'make check' worked for all of them; 'make install' seemed OK.

When use autoconf outside of its own directory, I get errors that I don't understand. For example, in my home directory I have a '' that contains


aclocal produces

% aclocal warning: AC_ARG_PROGRAM was called before AC_CANONICAL_TARGET
autoconf/general.m4:1657: AC_CANONICAL_TARGET is expanded from...
autoconf/general.m4:1660: AC_CANONICAL_SYSTEM is expanded from...

Running autoconf:

% autoconf error: possibly undefined macro: AM_INIT_AUTOMAKE
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation. error: possibly undefined macro: AC_PROG_GNU_M4 error: possibly undefined macro: AM_MISSING_PROG error: possibly undefined macro: AC_PROG_LIBTOOL

I don't really know autotools very well, and I have no idea how to deal with this. I've tried various things, looked around the documentation, checked the web, searched autoconf mail archives, but I'm still stuck. I'd appreciate suggestions.


Graham Mark

reply via email to

[Prev in Thread] Current Thread [Next in Thread]