[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

expected Autoconf 2.59 <-> 2.60 compatibility?

From: Ben Pfaff
Subject: expected Autoconf 2.59 <-> 2.60 compatibility?
Date: Tue, 09 May 2006 17:26:12 -0700
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/21.4 (gnu/linux)

Autoconf 2.50 was a major change, with a long development cycle,
that had plenty of incompatibility with older releases, so that
when I packaged it for Debian I kept a compatibility package
around for Autoconf 2.13.  This seems to be what other distros
and operating systems did as well.

Autoconf 2.60 has had a long development cycle too, but I'm
hoping that it is not sufficiently different from 2.59 to make it
necessary to package it separately from 2.59.  I'm basing this
mostly on the NEWS, which primarily lists new macros.  However,
it does list some behavioral changes as well, e.g. the change in
the expansion of @top_builddir@ and the behavior of

Does anyone have input on whether these changes are cumulatively
important enough to break much software?

Ben Pfaff 
email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]