[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs-22.0.99 configure problem

From: Stepan Kasal
Subject: Re: emacs-22.0.99 configure problem
Date: Thu, 3 May 2007 12:55:37 +0200
User-agent: Mutt/

[removed autoconf-patches from the cc list]

Hello all,
 I'm answering the easy questions to save some of Paul's time.

On Wed, May 02, 2007 at 11:15:07AM -0400, Richard Stallman wrote:
>     [...] a patched variant of the same version of Autoconf we use today.

ok, then grab the tarball of the Autoconf you use today, apply the
patch attached to this mail (applies cleanly to 2.61 and with some
offset to 2.60).  Then configure with some --prefix, install, enjoy.

(The version number will stay the same, but I do not think we should
be that strict, it's just a wording of a message, after all.)

Alternatively, place this definition to, _before_

  echo No shell found that supports shell functions.
  echo Please tell address@hidden about your system,
  echo including any error possibly output before this message.
  echo This can help us improve future autoconf versions.
  echo Configuration will now proceed without shell functions.

(Remember to replace that by AC_PREREQ([2.62]) when both your and our
releases are out.)

> [...] or just applying the same change directly to the configure file.

That's a way, too.  Just replace the text in the generated configure
by the new one.  (There is only one occurence.)

Happy hacking,

Attachment: patch-for-emacs.patch
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]