[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: how to modify configure?

From: Eric Blake
Subject: Re: how to modify configure?
Date: Tue, 26 May 2009 21:08:49 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20090302 Thunderbird/ Mnenhy/

Hash: SHA1

[please keep the list in the loop]

According to Imre Péntek on 5/26/2009 8:58 AM:
> On Tuesday 26 May 2009 14:00:19 you wrote:
>> That snippet comes from libtool, not autoconf. You are better off asking
>> on the libtool list, but my initial impression is that this is probably
>> something that we have already fixed when we made libtool's definition of
>> lt_echo be smarter and not require a sed prepass. Therefore, the best way
>> to fix your bug is to use newer libtool.
> Hello, actually this exact referenced snippet gets written into a file
> named libtool by the script config.status (generated by configure, which
> is of course generated by autoconf)
> So you state that that code (when written to the configure script) is
> actually taken from a script named libtool?

Actually, I meant that the text comes from the Libtool project, which, via
the libtoolize script, inserts macro code via your aclocal.m4 file that
eventually becomes part of configure and then config.status in order to
create your package's customized version of a libtool script.

> Which libtool?
> from /usr/bin/libtool ?
> this instance uses $ECHO everywhere, so there would be no need to set
> also the echo variable

Older libtool used $ECHO, newer libtool does not.

> thank you again in advance

As has already been pointed out, your problem is probably related to
having multiple, incompatible versions of libtool, such that some, but not
all, of the libtool inputs into configure were upgraded.  But again, you
are better off asking on the libtool list how to fix things, if you can't
figure it out by yourself, because it is not a bug in autoconf.

- --
Don't work too hard, make some time for fun as well!

Eric Blake             address@hidden
Version: GnuPG v1.4.9 (Cygwin)
Comment: Public key at
Comment: Using GnuPG with Mozilla -


reply via email to

[Prev in Thread] Current Thread [Next in Thread]