[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Broken makefile given Autoconf version mismatch

From: Stepan Kasal
Subject: Re: Broken makefile given Autoconf version mismatch
Date: Thu, 20 Apr 2006 14:52:31 +0200
User-agent: Mutt/1.4.1i

Hello Alexandre,

On Thu, Apr 20, 2006 at 02:03:14PM +0200, Alexandre Duret-Lutz wrote:
>  Stepan> I would suffice if autoconf, when called in 3) updated ./configure.
>  Stepan> (It presents only minimum of extra work.)
> I don't think it works :
>   - if automake is called by a rebuild rule to rebuild one
> with a new Autoconf version, all the other
>     Makefile.ins remain based on the other Autoconf version
>   - if autoconf is called by the rebuild rule of configure
>     then nothing guarantees that the existing Makefile.ins
>     are compatible.

you are right, thanks for correction. doesn't depend only on
configure's sources, but also on the version of Autoconf.

It is possible to fix it by replacing the dependency:

$(srcdir)/  $(srcdir)/ $(am__configure_deps)


$(srcdir)/  $(srcdir)/ $(top_srcdir)/configure

Would you like this amended proposal?

Have a nice day,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]