[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AM_INCLUDE is a bad name.

From: Pavel Roskin
Subject: Re: AM_INCLUDE is a bad name.
Date: Tue, 6 Feb 2001 10:09:37 -0500 (EST)

Hello, Tom!

> What if instead we decide on a permanent naming scheme for automake
> internal variables?  Then we can start moving towards that over time,
> starting here.
> What if instead we use `_AM_'?  Or `_am_'?

After another consideration I decided that AM_INCLUDE is not meant to be
private since it appears in AC_SUBST.

I have applied my patch as is (i.e. AM_INCLUDE -> AMINCLUDE), because it's
bad that the testsuite is failing in the middle of a major modifications.

I believe that we should move towards "use strict" in
Although it would catch just few errors, strict typing in large projects
(which Automake already is) is usually worth it.

Pavel Roskin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]