[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

random automake questions

From: David Petrou
Subject: random automake questions
Date: Tue, 19 Jun 2001 18:29:06 -0400
User-agent: Mutt/1.2.5i

Hi.  I have a few unrelated questions regarding automake.

1. I'm maintaining a library that uses automake.  After building my
library, I have test programs that run via `make check' to confirm
that everything's working properly.  These programs need to link into
the built (but not installed library).  These programs are in a
subdirectory called tests/ and my src is in a subdirectory called
`src/'.  Am I doing the right thing by specifying `LDADD =
../src/.libs/libpdl.a'.  After building, this seems to be the only
version of the library that's complete.  The file `src/libpdl.a' is
very short and obviously incomplete.

2. I've noticed that there's no target to make an html version of a
texinfo file.  I think for many users, html is preferable over info
and dvi.  Does it make sense for a target to exist and a standard
location to install html documentation?

3. On a related note, would it make sense for there to be a `make
postscript' target?  I can do things like `make' where `foo' is
the name of my package to get postscript, but it seems like something
complementary to `make dvi' would be more natural.  And so would a
rule for `pdf' (using ps2pdf?).

4. Using automake 1.4 on Red Hat Linux 7.1, I get a weird copying
error when doing 'automake --add-missing -c', yet, the file that I
needed (in this case, texinfo.tex) was copied perfectly:

localhost 0/342 ~/research/libpdl> automake --add-missing -c
doc/ installing `doc/texinfo.tex'
    error while copying

Looking at automake itself, I see:
           elsif (! system ('cp', $am_dir . '/' . $file, $errfile))
               $suppress = 0;
               $trailer = "\n    error while copying\n";

But doesn't `system' return 0 if everything goes well?

5. Another thing I've noticed: Shouldn't `make install' report a
warning to stdout if `install-info' isn't found?  I was scratching my
head for a while trying to figure out why my info files weren't being
reflected in my dir file before I realized that `install-info' wasn't
in my path.


P.S.: Please be sure to reply to me in addition to this list as I'm
not subscribed.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]