[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Two confusing problems

From: John Levon
Subject: Re: Two confusing problems
Date: Fri, 27 Jul 2001 02:19:38 +0100
User-agent: Mutt/1.3.19i

On Thu, Jul 26, 2001 at 05:46:29PM -0600, Tom Tromey wrote:

> If you sent him the output of `make dist' then he doesn't need to run
> autogen (which I assume runs aclocal, autoconf, and automake).  `dist'
> generates something ready to use.  He can just run `configure'.

he is another developer though, and therefore needs to do this - he's not just
compiling up (I'm aware of make dist, it's my favourite feature next to 
distcheck ;)

> Beyond that, his automake is too old.  He must upgrade.

this is what I wanted to know, thanks.

> Offhand I couldn't say.
> Mixing libtool verisons like this is probably a bad idea anyway.

I don't see I have much choice if I want people to be able to compile a
make disted tarball with different libtool versions. I didn't realise
things weren't compatible for users of make disted tarballs.

I had trouble locating information on exactly what the minimum requirements
were for :

1) users wrt libtool


2) developers wrt all the autotools

> John> 2) automake doesn't scan for AC_PROG_LIBTOOL, so it's kind of
> John> hard to not use the deprecated form ???
> I don't recall offhand, but that might be a problem with 1.4.
> He should upgrade automake.

this occurs in p4 as well, at least for me (I upgraded in an attempt to fix
this bug, didn't work)

> You can use AM_CXXFLAGS.  This will probably do what you want.
> This question is a FAQ.  I bet the autoconf macro archive, or the

yes, sorry, the last was a late night stupidity


"I'd rather be rudely informed than politely left in the dark."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]