[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Autoconf 2.59 doesn't work with automake-1.9

From: Stephen torri
Subject: Re: Autoconf 2.59 doesn't work with automake-1.9
Date: Tue, 07 Sep 2004 19:21:44 -0400

On Tue, 2004-09-07 at 16:03, Alexandre Duret-Lutz wrote:
> >>> "Stephen" == Stephen torri <address@hidden> writes:
> [...]
>  Stephen> bash-2.05b$ autoconf --version
>  Stephen> autoconf (GNU Autoconf) 2.59
>  Stephen> Written by David J. MacKenzie and Akim Demaille.
> The config.log you sent shows the output of Autoconf 2.13.  If
> you are running the above example and the failing configure from
> the very same shell session, it might be caused by a shell
> configuration that mistakenly reset PATH for non-login shells.

The problem is with the version of autoconf installed. I am on a Gentoo
system which they provide autoconf-2.13 and autoconf-2.59. Here are the
criteria that will cause autoconf-2.59 to be used over 2.13:

# - defaults to autoconf-2.13
# - runs autoconf-2.59 if it exists and...
#   - envvar WANT_AUTOCONF is set to `2.5'
#     -or-
#   - is present
#     -or-
#   - `' contains AC_PREREQ and the value's 3 first letters
#     are stringwise greater than '2.13'
#     -or-
#   - `configure' is already present and was generated by autoconf
greater than
#     '2.13'
#     -or-
#   - `' was generated by automake-1.6 or superior, which
#     specifically needs autoconf-2.59

What ever reason for the wrong autoconf to be used when there is a present I don't know. When I did "export WANT_AUTOCONF=2.5"
the check passed.

Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]