[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

I: adjust test suite for upcoming GNU Make 3.83

From: Dmitry V. Levin
Subject: I: adjust test suite for upcoming GNU Make 3.83
Date: Thu, 10 Mar 2005 18:45:53 +0300


Upcoming version of GNU Make introduces new incompatibility.
The NEWS file says:
* WARNING: Backward-incompatibility!
  GNU make now implements a generic "second expansion" feature on the
  prerequisites of both explicit and implicit (pattern) targets.  After
  the rule has been parsed, the prerequisites are expanded a second
  time, this time with all the automatic variables in scope.  This means
  that in addition to using standard SysV $$@ in prerequisites lists,
  you can also use complex functions such as $$(patsubst f%r,b%o,$$@) etc.
  This behavior applies to implicit rules, as well, where the second
  expansion occurs after the rule is matched.
  However, this means that you need to double-quote any "$" in your
  filenames; instead of "foo: boo$$bar" you must write "foo: foo$$$$bar"

GNU Make developers suggest to adjust dollar.test, to make it work with
both the old and new versions of GNU make, see

However, "automake-1.9 --foreign -Werror -Wall" issues warning when
":="-style assignment is used, so dollar.test fails in the adjusted form,


Attachment: pgpv1bE0TU0ZV.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]