[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: automake/492: Compilation of assembler files with subdir-objects

From: Thomas Schwinge
Subject: Re: automake/492: Compilation of assembler files with subdir-objects
Date: Thu, 12 Oct 2006 00:05:01 +0200
User-agent: Mutt/1.5.6+20040907i


On Wed, Oct 11, 2006 at 05:48:12AM +0200, Ralf Corsepius wrote:
> On Tue, 2006-10-10 at 16:15 +0200, Thomas Schwinge wrote:
> > On Sun, May 14, 2006 at 06:09:10AM +0200, Ralf Wildenhues wrote:
> > >

> > We were talking about the issue why Automake doesn't emit proper rules
> > for compiling (pre processed) Assembler files (the .S ones) when using
> > `AM_INIT_AUTOMAKE([subdir-objects])'.
> >
> > When using code file `libfoo_a_SOURCES = somewhere/a.S', Automake
> > currently assembles `somewhere/a.S' and puts `a.o' into the current
> > directory (as opposed to `somewhere/a.o'), but when creating `libfoo.a'
> > it wants to add `somewhere/a.o', which will then obviously fail.
> This is a known issue (reported > 2 years ago) and supposed to be fixed
> in automake-cvs (me and somebody else contributed patches to implement
> this behavior)

Indeed I can confirm that this isn't a problem anymore with the cvs
version of Automake.  Someone might close this bug report now.

> Unfortunately so far, there had not been a new automake release since
> then.

Is there already an estimation possible when this will happen?


Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]