[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

detect old Automake

From: Peter Johansson
Subject: detect old Automake
Date: Thu, 25 Feb 2010 11:23:05 -0500
User-agent: Thunderbird (X11/20090105)

Hi all,

In a project I have a couple of autoconf macros, which are tested during `make check' by building a minimal package using the packages. Since autotools is not a requirement for my package I want to skip the test when autoconf or automake is not available. Done! I recently learnt that the tests fail when old autotools were used so I wanna skip the test also when old autotools are used. With Autoconf that seems to be easy because AC_PREREQ exits with status 63 when compiled with an old Autoconf. I wonder if there is a similar trick available for Automake. For consistency and convenience it would be nice if Automake also returned 63 when an too old version was used. Is there any reason against that or would a patch be welcome?


Peter Johansson

svndigest maintainer,
yat maintainer,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]