[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCHES] {maint} honour configure-time AUTOCONF and AUTOM4TE (was:

From: Stefano Lattarini
Subject: Re: [PATCHES] {maint} honour configure-time AUTOCONF and AUTOM4TE (was: Re: make check failures)
Date: Sun, 29 May 2011 15:05:38 +0200
User-agent: KMail/1.13.3 (Linux/2.6.30-2-686; KDE/4.4.4; i686; ; )

[dropping automake-patches]

On Sunday 29 May 2011, Stefano Lattarini wrote:
> [Adding automake-patches]
> On Saturday 28 May 2011, Graham Reitz wrote:
> > Hi Stefano,
> > 
> > Did you have a chance to take a look at the config and test logs?
> > (they are attached)
> >
> > I've been trying to figure it out without much success.
> >
> I think I've found the problem: the `' and `'
> "templates" (from which the `aclocal' and `automake' scripts are
> generated) fail to honour the AUTOCONF and AUTOM4TE defined at
> configure time, and simply use literal "autom4te" and "autoconf"
> instead.  This is a real bug in Automake's own build system, and
> is still present in the latest developement version.  The attached
> two-patches series (for maint) should fix it.  Graham, do you mind
> trying if it solves your problem?
Notwithstanding this patch, I'm convinced that there are still bugs
and rough-edges in the support for overriding AUTOCONF and AUTOM4TE
at configure time.  Thus I suggest Graham (and any other user in a
similar situation) to follow the previous suggestions by Daniel
i.e. simply put the latest versions of the autotools early in PATH,
and set up a proper `dirlist' file for them in case third-party
m4 macros are used.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]