[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gnu-prog-discuss] Could automake-generated Makefiles required GNU m

From: Paolo Bonzini
Subject: Re: [gnu-prog-discuss] Could automake-generated Makefiles required GNU make?
Date: Tue, 22 Nov 2011 17:03:41 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20110930 Thunderbird/7.0.1

On 11/22/2011 04:35 PM, Stefano Lattarini wrote:
  1. "Automake 2" turns out to be a failure, it gets abandoned, and
     "Automake 1" becomes again the center of all our developement
     efforts.  No problem for you, since you're still using this older

  2. "Automake 2" is a success, and we drop support for Automake 1.  At
     this point, it shouldn't be too big a pain for you to convert to the
     new automake (a good documentation about incompatibilities between,
     and/or transition from, automake 1 and 2 should exist at this point).
     Also, assuming that many other packages are using automake 2 by now,
     and thus requiring GNU make, it should be much more acceptable for
     the NTP build system to do the same.

A half transition happens, which turns out to be a nightmare until Automake 2 adoption actually becomes common. This is exactly what happen between Automake 1.5 and Automake 1.8, each of which introduced many backwards-incompatible features, and between Autoconf 2.50 and "some time later".


reply via email to

[Prev in Thread] Current Thread [Next in Thread]