[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-chat] avrdude setting internal osc

From: Dean Hall
Subject: [avr-chat] avrdude setting internal osc
Date: Wed, 16 Jan 2008 15:47:43 -0600


Dev hardware: Mac OS X 10.4 PowerPC, Keyspan USA-19HS, Atmel STK500v2, 10-pin ISP cable to target system.
Dev software: OSX-AVR: avrdude 5.3.1

I had a working ATmega8 system running with an internal oscillator at the default rate of 1 MHz. My customer wants to run at 8 MHz, so I used avrdude to set the fuse bits like this:

$ avrdude -p atmega8 -P /dev/cu.KeySerial1 -c stk500v2 -V -t
avrdude> write lfuse 0 0xE8
>>> write lfuse 0 0xE8
avrdude> read lfuse
>>> read lfuse
0000 e8 |. |
avrdude> quit
>>> quit

As you can see, I used the value 0xE8, not 0xE4 like I should have. Now, I cannot reconnect via avrdude:

$ avrdude -p atmega8 -P /dev/cu.KeySerial1 -c stk500v2 -V -t
avrdude: stk500v2_command(): command failed
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.
avrdude done.  Thank you.

I have tried setting the bit clock by adding this to the command line, "-B 1.0" on up to "-B 4.0" with no luck. I have tried chip erase "-e" with no luck. Is there a way for me to re-establish comms with the ATmega8? Resetting the fuses to defaults would be nice.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]