[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] uisp problem

From: Torsten Hahn
Subject: [avr-gcc-list] uisp problem
Date: Wed, 14 Apr 2004 14:03:32 +0200


i hav build a serial programmer AVR-PG1B as shown on www.olimex.com/dev and i have trouble to get it to work with uisp. I connected the cable direct to the avr device (mega128) like shown in the doc:

1 -> MOSI (Pin 12)
2 -> +5V (Pin 52)
5 -> Reset (Pin 20)
6 -> GND (Pin 53)
7 -> SCK (Pin 11)
9 -> MISO (Pin 13)

the cable sits in the first serial port of my linux box, but an

uisp -v=4 -dprog=dasa -dlpt=serial -dserial=/dev/ttyS0 --erase

Reset inactive time (t_reset) 1000 us
AVR Direct Parallel Access failed after 32 retries.
Vendor Code: 0x00
Part Family: 0x00
Part Number: 0x00
Probably the AVR MCU is not in the RESET state.
Check it out and run me again.

I also tried to use PDI (Pin2) and PDO (Pin3) of the mega128 instead of MISO and MOSI but with the same result. It looks like the chip is not responding. I have also a parallel port programmer (STK200) wich works fine. Any ideas ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]