[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes

From: Joerg Wunsch
Subject: Re: [avr-gcc-list] Re: [avr-libc-dev] RFD: more avr-libc API changes
Date: Thu, 8 Sep 2005 21:30:44 +0200
User-agent: Mutt/

As Zane D. Purvis wrote:

> How about changing the name to "ISR," which would do the same thing
> as the existing "SIGNAL"?

> Then, SIGNAL and INTERRUPT can both be deprecated (avoiding future
> confusion).

It has been suggested before, but so far, nobody else seemed to
care about that suggestion.

I'm open for it.  I'd probably rather deprecate SIGNAL with a much
lower priority than INTERRUPT, as there's no strong need to force that
change upon virtually every AVR-GCC program around, but I don't mind
such a change.

cheers, J"org               .-.-.   --... ...--   -.. .  DL8DTL

http://www.sax.de/~joerg/                        NIC: JW11-RIPE
Never trust an operating system you don't have sources for. ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]