[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] Re: AVR-GCC-list Digest, Vol 25, Issue 10

From: Keith Gudger
Subject: [avr-gcc-list] Re: AVR-GCC-list Digest, Vol 25, Issue 10
Date: Fri, 23 Feb 2007 08:19:48 -0800
User-agent: Thunderbird (X11/20061206)

Thanks Joerg for your reply to my previous post about avr-gcc compile
problems.  I'm finally getting back to this issue, and am still not
able to compile avr-gcc for the same reasons.  Since the last post I
completely rebuilt binutils-2.17 and reconfigured and tried to make
avr-gcc, with the same results.  This is being done on RedHat 8.0, so
the build environment is rather old.

avr-gcc make still returns:
/usr/bin/avr-as: unrecognized option `-Qy'
make[2]: *** [g++spec.o] Error 1
make[2]: Leaving directory `/usr/local/src/gcc-4.1.1/objdir/gcc'

Which I realize is because avr-as doesn't recognize -Qy

I tried your idea of running strace, but that doesn't work on this system:
strace -o logfile -f make
PANIC: setbpt for syscall 190 on 30358???
Process 30359 attached
Process 30358 suspended

More info:
> sh-2.05b$ which as /usr/bin/as sh-2.05b$ which avr-as
> /usr/bin/avr-as sh-2.05b$

The avr-as is an old version on this system - it's in the PATH before
the latest from binutils-2.17.  If I change the path so that the new
one is earlier, I get the same problem, -Qy not recognized.

I don't see where -Qy is getting passed to the assembler.
Any help appreciated.  Thanks.

> In article
> <address@hidden> you
> write:
>> ../configure --target=avr --prefix=/usr/local/avr4 --with-dwarf2
>> --enable-languages=c,c++ --disable-libssp --disable-nls
>> /usr/local/avr4/bin/avr-as: unrecognized option `-Qy'
> For whatever reason, it's confusing the host system's
> compiler/assembler options with the target options.  -Qy is an
> option to System V Release 4 (UNIX, "SVR4") assemblers, which is
> effectively ignored in gas.
> You can try stracing that part of the build:
> strace -o logfile -f make
> Then look into the logfile for all the files it is opening, and the
>  commands it is executing.
> Just to make sure: you did configure your avr-binutils with the
> same prefix, did you?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]