[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-gcc-list] ATMEGA2560 support

From: Dale Whitfield
Subject: [avr-gcc-list] ATMEGA2560 support
Date: Sun, 6 Apr 2008 15:40:54 +0200
User-agent: Mutt/1.5.13 (2006-08-11)


This feels like it should be a FAQ but I can't find any definitive
answers in archives anywhere.

I'm looking to compile for atmega2560 using:
avr-gcc 4.2.3
avr-libc 1.6.1

These are fairly recent and installed from Debian packages. 

Thinking something was left out since there was no avr6 directory in the
lib - I compiled avr-libc and discovered that it was missing because the
compiler doesn't support atmega2560... (also tried building avr-libc
1.6.2 which resulted in empty lib/avr6/atmega256x directories). Seems
like a catch-22 at play here!

Specifying -mmcu=atmega2560 gives the message that its supported by the
assembler only. I've seen that reported but not what the solutions are.

I have a makefile which tells the assembler to generate code for
atmega2560, but not the compiler. I'm assuming the compiler needs
something or it defaults to avr2 which is surely incorrect?!

I guess the questions are: 
o What combination of 'mcu' values is required?
o What linker script to use (I want to include a boot-loader, etc and
therefore customise it)?
o Is there a 'known good' compiler/lib set for atmega256x?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]