[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avrdude-dev] Building AVRDUDE 5.2 under cygwin @WINDOWS_DIRS@: No such

From: Bob Paddock
Subject: [avrdude-dev] Building AVRDUDE 5.2 under cygwin @WINDOWS_DIRS@: No such file or directory
Date: Tue, 07 Nov 2006 11:10:58 -0500
User-agent: Opera Mail/9.02 (Win32)

I am trying to build AVRDUDE 5.2 under Cygwin.
I have updated my Cygwin environment to the latests
versions of the various tools, this morning.
Then I deleted my old 'avrdude' directory and
checked everything out of cvs, this morning.

I have run the script at the end of this message
to get 'configure' and 'Makefile' created.

When I run the resultant makefile I get the
following error:

make  all-recursive
make[1]: Entering directory `/cygdrive/g/HOME/avrdude'
Making all in @WINDOWS_DIRS@
/bin/sh: line 17: cd: @WINDOWS_DIRS@: No such file or directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/cygdrive/g/HOME/avrdude'
make: *** [all] Error 2

I have tried setting WINDOWS_DIRS in my environment
before creating 'configure', and I get the same error.

What do I have set up wrong?

autogen.sh based on autogen.sh from PCB project:

#! /bin/sh
# Run the various GNU autotools to bootstrap the build
# system.  Should only need to be done once.

# for now avoid using bash as not everyone has that installed

echo "Running aclocal..."
aclocal $ACLOCAL_FLAGS || exit 1
echo "Done with aclocal"

echo "Running autoheader..."
autoheader || exit 1
echo "Done with autoheader"

echo "Running automake..."
automake -a -c --foreign || exit 1
echo "Done with automake"

echo "Running autoconf..."
autoconf || exit 1
echo "Done with autoconf"

echo "You must now run configure"

echo "All done with autogen.sh"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]