[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Axiom-developer] Axiom silver branch

From: Ralf Hemmecke
Subject: Re: [Axiom-developer] Axiom silver branch
Date: Wed, 12 Apr 2006 21:04:04 +0200
User-agent: Thunderbird 1.5 (X11/20051201)

You said that now Axiom (via gcl) depends on Emacs, but I guess you don't want to include emacs into axiom--main--1, do you? (Otherwise axiom does not "just work". ;-) )

It appears that GCL depends on some awk/sed change that somehow
gets packaged with emacs (I'm guessing since I don't actually know the source but Camm has suggested that might be the problem).

I'm going to find the problem and write a GCL patch so that it
no longer occurs, send the patch to Camm, and put the patch in zips
against the current GCL versions.

That way Axiom 'just works'.

Curiously the issue first arises on a debian system which is supposed
to be really good at the whole dependency handling.

I somehow cannot believe that the problem is an issue with emacs, since I work also on Debian Sarge on my laptop (maybe with a few other packages installed). And I have no proplem with compiling Axiom.

Looking at that ...

checking emacs site lisp directory... Warning: Lisp directory `/usr/local/share/emacs/site-lisp' does not exist.

... one difference is that at my laptop this directory exists.
Don't know how relevant that is, though.

checking emacs default.el... ./configure: line 6216: test: too many arguments

Hmmm. the above line looks like a bug in ./configure.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]