[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bison 2.4.1: make install does not install mo files

From: Bruno Haible
Subject: Re: Bison 2.4.1: make install does not install mo files
Date: Mon, 17 Aug 2009 10:36:26 +0200
User-agent: KMail/1.9.9

Akim Demaille wrote:
> I installed the following in 2.4.2, 2.5, and master.


> >>    AM_GNU_GETTEXT_VERSION([0.15])
> >
> > This version has a different meaning: it tells which macros
> > (intl.m4 etc.) you want to include in your release tarball.
> Our bootstrap.conf prevents their distribution (same commit).

gettext.m4, intlmacosx.m4 etc. are included in the distribution,
fortunately. (Omitting .m4 files required to build the configure
file, other than GNU automake ones, would be seen as a bug.)
But they are omitted from the version control, which is fine -
this is precisely what AM_GNU_GETTEXT_VERSION is for.

Nonetheless, you may at some point switch to 0.17, by
  1) installing gettext 0.17 yourself,
  2) invoking gettexize from that version. It will change
     the line to
I say this because bison is also using gnulib, and I guarantee
that there are no conflicts between the latest gnulib and the
latest released gettext (0.17 at this moment), but I don't guarantee
the absence of conflicts between the newest gnulib and older
gettext releases.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]