[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-apl] Parsing error?

From: David Tran
Subject: Re: [Bug-apl] Parsing error?
Date: Thu, 12 May 2016 16:54:29 -0400

Thanks Christian to show new version ( and also show me how to build ).

I was able to get source code from SVN trunk and manually build ( or use brew install --build-from-source ) successfully, but missing readline library.

Yes, I am using Mac and brew ( that's why my GNU APL is old; version 1.4 from brew install; and no brew formula yet for 1.5 ).
I already installed readline ( brew install readline ) before.
Tried set up LDFFLAGS and CPPFLAGS to point to directory of readline, but still no luck.
And there seems no configuration option about setting readline directory ( only option to without readline )
I saw there is a ax_lib_readline.m4 seems to detect existence of readline library, but cannot figure out how to force the flag to true.

Anyone is using Mac ( + brew ) and successful to build SVN trunk GNU APL with readline library? Can you enlighten?


On Tue, May 10, 2016 at 5:47 PM, David Tran <address@hidden> wrote:

I am newbie on APL, so I am not sure below is a bug or not :-)

      v ← (1 2 3) (4 5 6)
      f ← {1+⍵}
      f (⊂ 1 0 1)/¨v
      f(⊂1 0 1)/¨v
      ^          ^

However, adding parentheses works:
      f((⊂1 0 1)/¨v)
 2 4  5 7 

But f is function, with APL's right-associative rule, it should no need parentheses for f.
( Tested with TryAPL.org without parentheses and work without error )

BTW. here is my version info:
~ $ apl -v
  Project:        GNU APL
  Version / SVN:  1.4 / 7887
  Build Date:     2014-08-07 15:46:58 UTC
  Build OS:       Linux 3.11.0-12-generic x86_64
  Readline:       0x0603


reply via email to

[Prev in Thread] Current Thread [Next in Thread]