[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: autoconf-2.62 doesn't build on RHEL4

From: Ralf Corsepius
Subject: Re: autoconf-2.62 doesn't build on RHEL4
Date: Wed, 23 Apr 2008 10:44:17 +0200

On Tue, 2008-04-22 at 19:18 +0200, Ralf Wildenhues wrote:
> Hello Ralf,
> * Ralf Corsepius wrote on Tue, Apr 22, 2008 at 03:41:36PM CEST:
> > On Tue, 2008-04-22 at 07:19 -0600, Eric Blake wrote:
> > > You're comparing apples and oranges. 
> > I don't see this ... You require a particular version of gm4 instead of
> > searching for a feasible, sufficient "m4" (note: m4 vs. gm4).
> Autoconf has required GNU m4 for a looong time.
Well, when this had been decided, GNU m4 had been assumed to be a viable
and stable basis.

autoconf-2.62 has proven this assumption to be wrong.

> Really, we require newer m4 because older versions caused autoconf to
> create erroneous configure scripts, and those errors were very difficult
> to diagnose.  Not to make life harder for you.
It might be inconvenient to you but reality simply is as simple as:
Autoconf-2.62 has proven to miss its objective: portability.

May-be RH realizes that RHEL4 doesn't meet autoconf's requirements and
therefore doesn't qualify as suitable platform for ongoing
development :/ Them upgrading their toolchains, would help us, but of
cause doesn't help autoconf in general.

Anyway, we just decided to drop supporting RHEL 4 from our supported
platforms portfolio and decided to stay with autoconf-2.61 for the
current branch of our development - It's a pity, but all this is a
direct consequence of autoconf-2.62.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]