[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: automake-1.7.3: single test failure on NetBSD 1.6, and autoconf-2.57

From: Nelson H. F. Beebe
Subject: Re: automake-1.7.3: single test failure on NetBSD 1.6, and autoconf-2.57
Date: Mon, 14 Apr 2003 06:12:30 -0600 (MDT)

Thanks very much for the explanation of the prefix setting problem in
configure on NetBSD that resulted in a test failure for
automake-1.7.3.  I can indeed confirm your suspicion:

        % uname -a
        NetBSD netbsd.vm.math.utah.edu 1.6 NetBSD 1.6 (GENERIC) #0:
        Sun Sep 8 19:43:40 UTC 2002
        i386 i386 Intel Pentium III (Katmai) (686-class) NetBSD

        % echo $prefix

        % env TESTS=man2.test make check -e

        % grep '^prefix' testSubDir/config.log

The automake-1.7.3 script was generated by autoconf-2.57.

I've noticed similar problems in builds of several other packages on
systems where I have prefix set to something other than /usr/local:
I still get


in the Makefile, instead of the correct value from the environment.
However, until now, I'd not correlated this with the autoconf
version.  I'll have to check that in the future.

- Nelson H. F. Beebe                    Tel: +1 801 581 5254                  -
- Center for Scientific Computing       FAX: +1 801 581 4148                  -
- University of Utah                    Internet e-mail: address@hidden  -
- Department of Mathematics, 110 LCB        address@hidden  address@hidden -
- 155 S 1400 E RM 233                       address@hidden                    -
- Salt Lake City, UT 84112-0090, USA    URL: http://www.math.utah.edu/~beebe  -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]