[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cygwin: texi2dvi stumbles over texinfo.tex

From: Ralf Wildenhues
Subject: Re: Cygwin: texi2dvi stumbles over texinfo.tex
Date: Fri, 26 May 2006 06:46:21 +0200
User-agent: Mutt/1.5.11+cvs20060403

Hi Karl,

* Karl Berry wrote on Fri, May 26, 2006 at 12:04:15AM CEST:
> This line in fmtutil.cnf indicates the problem:
> etex          pdfetex         language.def    -translate-file=cp227.tcx 
> *etex.ini
> Either (1) the second word should be changed to "etex", or
> (2) it should be arranged for "etex" in invoke pdfetex instead of etex.
> E.g., make "etex" a link to pdfetex, instead of its own binary.

> I suspect you could also work around this Cygwin configuration bug by
> setting TEX=tex before running texi2dvi.

Bingo, thanks for the analysis!  First, setting TEX=tex solves the
issue.  Then I tried changing above line.  That worked after removing
the ~/.texmf/var/web2c/etex.fmt file from previous tests.  I did not try
making etex a link to pdfetex.

So now the Automake tests are looking much better: I'm down to one
failure related to this: txinfo18.test quits with a segmentation fault
of texindex, called by texi2dvi.

Attached are the verbose output of the test, the output of
  sh -x texi2dvi --pdf --batch ../main.texi

and a script showing the stack dump of texindex as well as the source


Attachment: log-txinfo18.test
Description: Text document

Attachment: pdflog
Description: Text document

Attachment: typescript2
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]