bug-automake
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#31883: Incompatibility with new Perl versions


From: Mitja Stachowiak
Subject: bug#31883: Incompatibility with new Perl versions
Date: Mon, 18 Jun 2018 11:21:19 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0

Hello,

I found a bug in http://ftpmirror.gnu.org/automake/automake-1.15.tar.xz -> bin/automake.in

At line 3881: Escape the outer {} with \. The correct line should look like this:

$text =~ s/\$\{([^ \t=:+{}]+)\}/substitute_ac_subst_variables_worker ($1)/ge;

Since newer versions, Perl enforces the escape of this brackets.

Greetings,
Mitja Stachowiak.

--
Mitja Stachowiak ­čöĺ PGP
Website: mitjastachowiak.de Telefon: 061629659002
Adresse: Darmst├Ądter Stra├če 16; 64354 Reinheim; Germany

Attachment: signature.asc
Description: OpenPGP digital signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]