[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash 3.1 on Solaris 9

From: Bob Proulx
Subject: Re: bash 3.1 on Solaris 9
Date: Thu, 13 Jul 2006 23:31:40 -0600
User-agent: Mutt/1.5.9i

Cheltenham, Christopher J wrote:
> What can I do for this error?
> ld.so.1: bash: fatal: libiconv.so.2: open failed: No such file or
> directory
> Killed

You apparently got a precompiled binary from some third party.  That
binary is using a shared library that it did not include.  Probably at
the same place that you got the bash binary you would also find the
libiconv shared library.  Install it too.  Repeat as needed.

Or you could pull the source code to bash and compile it yourself
which would build it without that dependency.  The GNU project
generally distributes source code.  A whole infrastructure of third
parties have developed around compiling the source code and
distributing it.  But really anyone can compile the code and this is


reply via email to

[Prev in Thread] Current Thread [Next in Thread]