[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Powerpc Linux build fails

From: Keith Pickens
Subject: RE: Powerpc Linux build fails
Date: Tue, 18 May 2004 11:06:00 -0500

Sorry, I wasn't saying the change was wrong but rather that it
has a side effect that broke builds that have worked for a
long time.

This test (arch/ppc/Makefile) now fails:

ifdef CONFIG_6xx
# Ensure this is binutils 2.12.1 (or or later
NEW_AS  := $(shell echo dssall | $(AS) -o /dev/null >/dev/null 2>&1 ; echo
GOODVER := 2.12.1

The binutils configure:

configure --target=powerpc-slc-linux
--prefix=/home/ksp/wk/toolchain/build/stage1 \
--program-prefix=ppc_82xx- --disable-nls \

My compiler is configed for a 603e.  I tried reconfiging for a AltiVec cpu
and reworking
the Makefile to remove the test.  This did not get the ASM startup code to
build. It
still failed on the AltiVec code.  The compiler (gcc) was not passing the
flag [note: I think I picked an AltiVec cpu (7400) but I am not 100% sure].


> -----Original Message-----
> From: Ian Lance Taylor
> Sent: Monday, May 17, 2004 12:04 PM
> To: Keith Pickens
> Cc: 'address@hidden'
> Subject: Re: Powerpc Linux build fails
> Keith Pickens <address@hidden> writes:
> > A recent change to opcodes/ppc-opc.c breaks powerpc kernel builds:
> > 
> > 2004-05-05  Alan Modra  <address@hidden>
> > 
> >         PR 146.
> >         * ppc-opc.c (PPCVEC): Remove PPC_OPCODE_PPC.
> > 
> > This change appears to remove the default AltiVec support 
> which is required
> > for ppc
> > kernel builds.
> How is your compiler configured?
> Altivec instructions shouldn't be supported by default, since they are
> not supported on all PowerPC chips.  You can use -maltivec to turn on
> Altivec support, or you can use a toolchain for which the default CPU
> includes Altivec support.  There may be a bug, of course, but Alan's
> specific change appears clearly correct.
> Ian

reply via email to

[Prev in Thread] Current Thread [Next in Thread]