[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug ld/1150] undefined reference to `_mpi_sgi_init'

From: michael at weiser dot dinsnail dot net
Subject: [Bug ld/1150] undefined reference to `_mpi_sgi_init'
Date: 23 Nov 2005 21:32:19 -0000

------- Additional Comments From michael at weiser dot dinsnail dot net  
2005-11-23 21:32 -------
Created an attachment (id=766)
 --> (http://sourceware.org/bugzilla/attachment.cgi?id=766&action=view)
generalise previous patch, depends on earlier MIPS-OPTIONAL patch

Welcome back, Nick,

> Excellent!  I am a little bit hesitant to apply your patch as it is 
> however since it adds target specific code to a file that is meant to be 
> generic.  Could you investigate changing your patch so that it adds a 
> new elf backend function which can be called when an undefined symbol is 
> encountered and which allows individual backends to decide if the symbol 
> can be ignored ?

Mhmm, I actually wanted to avoid that since I don't have the slightest idea of
how bfd works. But I gave it a try anyway. Find the result attached for piping
to /dev/null. ;)

BTW: I compiled lots of stuff on my Octane with the binutils patched with the
earlier non-generic patch. All seems to work fine now, for example glib-2.8.3
with threading. make check completes 100% successful.



           What    |Removed                     |Added
 Attachment #757 is|0                           |1
           obsolete|                            |


------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]