[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug ld/4538] add --all-init flag to force all static initializers to be

From: cnmnzusoib at mailinator dot com
Subject: [Bug ld/4538] add --all-init flag to force all static initializers to be loaded
Date: 7 Aug 2007 05:17:49 -0000

------- Additional Comments From cnmnzusoib at mailinator dot com  2007-08-07 
05:17 -------
Apparently not.  :-P
Now, disabling my bugzilla account -- that's *really* classy.  Glad to know I'm 
dealing with a 
professional adult, not a hyperventilating dictator-for-life ("because I said 
so, that's why!  Respect my 

So... would any of the *other* "Blanket Write Privs" types care to step in and 
explain why adding an --
all-init flag would be such a terrible idea that it shouldn't be even 
considered as a possible future 
enhancement?  (quick summary: --all-init is like --whole-archive, but just for 
those units with static 
initialization sections, so stuff like 'int register = 
doFactoryRegistration<Foo>("Foo");' actually gets 
called reliably...)

If there's actually some rationale here, I'd be happy to move on.  If Mr. 
Modra's just abusing his power 
to do a quick sweep of his plate under the carpet so he can look efficient at 
closing bugs, I'm not so 

           What    |Removed                     |Added
             Status|RESOLVED                    |REOPENED
         Resolution|WONTFIX                     |


------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]