[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug binutils/4970] new library handling in binutils causes trouble with

From: nickc at redhat dot com
Subject: [Bug binutils/4970] new library handling in binutils causes trouble with --enable-shared
Date: 2 Oct 2007 12:16:45 -0000

------- Additional Comments From nickc at redhat dot com  2007-10-02 12:16 
Subject: Re:  new library handling in binutils causes trouble
 with --enable-shared

Hi Mike,

> the way to reproduce is:
>  - build/install binutils like normal except add --enable-shared to configure
>  - build/install binutils again with --enable-shared, and it'll fail during 
> the
> compile stages

(Just to confirm: between the first step and the second step above I should 
change my PATH so that the newly installed binaries from the first step are now 
ahead of any other binaries and so will be used in the build of the second 

I tried this, but both builds and installs ran to completion and I was able to 
run the resulting installed binaries without problems.

One possible cause for this was that I was using the current mainline sources 
with the patch from this email applied:


Although the patch is for a related problem I am not sure that it is 
responsible for making my builds/installs work whereas yours do not.  Could you 
put together a small shell script that I could use to reproduce the problem ?

> my fix for the problem would be to not set LD_LIBRARY_PATH at all

Do you have a patch that does this, so that I could take a look at it ?




------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]