[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug ld/6741] Linker test is broken

From: csilvers at google dot com
Subject: [Bug ld/6741] Linker test is broken
Date: 12 Jul 2008 21:41:06 -0000

------- Additional Comments From csilvers at google dot com  2008-07-12 21:41 
Subject:  PATCH COMMITTED: use libz for ld

The ld directory testsuite was failing because the boostrap tests
needed to use libbfd, and now need zlib to go along with that.  I
fixed the test by adding libz to the ld configure.in script, which is
similar to the solution used in the sims directory.

I committed this as an 'obvious' patch.  If that was the wrong thing
to do, please let me know.


--cut here--

2008-07-12  Craig Silverstein  <address@hidden>

        * configure.in: Check for, and include, libz.a if it is present.
        * configure: Regenerate.
        * config.in: Regenerate.

Index: configure.in
RCS file: /cvs/src/src/ld/configure.in,v
retrieving revision 1.52
retrieving revision 1.53
diff -u -r1.52 -r1.53
--- configure.in        21 May 2008 12:01:35 -0000      1.52
+++ configure.in        12 Jul 2008 21:36:53 -0000      1.53
@@ -148,6 +148,10 @@
 AC_CHECK_DECLS([strstr, free, sbrk, getenv, environ])
+# Link in zlib if we can.  This is needed only for the bootstrap tests
+# right now, since those tests use libbfd, which depends on zlib.
+AC_SEARCH_LIBS(zlibVersion, z, [AC_CHECK_HEADERS(zlib.h)])
 # When converting linker scripts into strings for use in emulation
 # files, use astring.sed if the compiler supports ANSI string
 # concatenation, or ostring.sed otherwise.  This is to support the



------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]